Requirements

Before diving right into the installation of FOG you need to decide which server OS you are going to use. FOG is made to install on RedHat based distro CentOS, Fedora, RHEL amongst others as well as Debian, Ubuntu and Arch Linux.

Choose whichever you like most and have knowledge about! FOG is known to work with any of the above noted systems. Many installation manuals are available.

This listing is for informational purposes only, as the required components will be automatically downloaded and installed by the FOG installation script:

  • PHP 5/7

  • MySql 5+/MariaDB 10+,

  • Apache 2+,

  • DHCP (pretty much any!)

  • TFTP

  • FTP

  • NFS

The LAMP setup can also be easily adjusted for a “WAMP (Windows Apache MySQL PHP) system” though will require a bit more knowledge of what packages to use and how to integrate with the FOG system.

Please choose the distribution you have the most knowledge about. This list is by no means an absolute list to follow, though.

  • Ubuntu 16 or higher

  • Debian 8 or higher

  • CentOS 7 or higher

  • Red Hat 6 or higher

  • Fedora 22 or higher

  • Any version of Arch.